Repository navigation
chore(deps): update dependency markdownlint-cli to ^0.50.0 - #3168
Merged
Merged
Conversation
Contributor
|
🗑️ Preview for this PR was deleted. |
renovate
Bot
force-pushed
the
renovate/markdownlint-cli-0.x
branch
3 times, most recently
from
November 5, 2026 22:17
46b1c23 to
0588900
Compare
B4nan
pushed a commit
that referenced
this pull request
Nov 6, 2026
… alerts (#3191) ## Summary Dependency sweep — this repo has `lockfileRefresh: false`, so no broad lockfile freshening this run, only targeted security bumps + override pruning. None of the 17 open alerts' vulnerable copies could be moved in-range this run (see 🚩 below for why); `pnpm update` for each candidate package, including after clearing the pnpm metadata cache, left the lockfile unchanged. ## 🧹 Pruned overrides (no longer needed) - `copy-webpack-plugin>serialize-javascript` (`^7.0.4`) — no-op: `copy-webpack-plugin@11.0.0`'s own declared range (`^6.0.0`) already resolves to the patched `6.0.2` without the override, and the docs sites build with Docusaurus's **rspack** bundler, so this webpack-only plugin doesn't even run. - `css-minimizer-webpack-plugin>serialize-javascript` (`^7.0.4`) — same reasoning: `css-minimizer-webpack-plugin@5.0.1`'s own range (`^6.0.1`) resolves to `6.0.2` unaided; also rspack-unreachable. - `lodash` (`^4.18.0`) — no-op: removing it only drops the locked copy from `4.18.1` to `4.17.21` (the terminal, fully-patched 4.17.x release — all known lodash CVEs were fixed by 4.17.21), so it wasn't blocking anything currently vulnerable. Kept `openapi-to-postmanv2>js-yaml` and `yaml@1` — removing either lets a genuinely older/vulnerable copy (`js-yaml@4.1.0`, `yaml@1.10.x`) back in. ## 🚩 Flagged — needs review - `minimatch` 10.2.6 → none available (MEDIUM) — no fix anywhere upstream yet: pinned by `markdownlint-cli@0.49.1` (`~10.2.6`), and even `markdownlint-cli@0.50.0` latest still pins `~10.2.6`. ([alert #336](https://github.com/apify/apify-docs/security/dependabot/336)) - `joi` 17.13.3 → 17.13.9 (×6 alerts) — in-range per `@docusaurus/types@3.10.2`'s own `^17.9.x`, but `pnpm update joi -r` (including with a cleared metadata cache) leaves it locked at 17.13.3 despite 17.13.9 being a month-old, clearly mature release — resolver bug, not a missing override; re-verify next run. ([alert #335](https://github.com/apify/apify-docs/security/dependabot/335), [#303](https://github.com/apify/apify-docs/security/dependabot/303), [#287](https://github.com/apify/apify-docs/security/dependabot/287), [#280](https://github.com/apify/apify-docs/security/dependabot/280), [#278](https://github.com/apify/apify-docs/security/dependabot/278), [#253](https://github.com/apify/apify-docs/security/dependabot/253)) - `decode-uri-component` 0.4.1 → 0.5.1 (×2 alerts) — needs a new override: pulled via `query-string@8.2.0` (used at runtime via `@apify/ui-library`), whose own range (`^0.4.1`) excludes both patches (`0.4.2` and `0.5.1` are both outside `^0.4.1`'s `0.4.x` window). ([alert #331](https://github.com/apify/apify-docs/security/dependabot/331), [#274](https://github.com/apify/apify-docs/security/dependabot/274)) - `smol-toml` 1.7.2 → 1.9.0 and `js-yaml` 5.2.3 → 5.5.0 — both need the same `0.x`-line bump `markdownlint-cli ^0.49.1 → ^0.50.0` (which pins `smol-toml ~1.9.1` and `js-yaml ~5.5.0`); the other locked `js-yaml` copy (`5.4.1`, via `openapi-to-postmanv2`) is already patched by the existing override, which stays. → tracked by #3168. ([alert #307](https://github.com/apify/apify-docs/security/dependabot/307), [#286](https://github.com/apify/apify-docs/security/dependabot/286)) - `tinypool` (×2 alerts, CRITICAL) — two separate copies, both no-fix-in-range: - `1.1.1` via `@docusaurus/core@3.10.2` (`^1.0.2`) — no patched 1.x release exists; docusaurus 4.x (which would move off tinypool 1.x) is canary-only. - `2.1.0` via `oxfmt@0.60.0` (exact pin) — needs `oxfmt 0.60.0 → 0.76.0` (pins `tinypool 2.2.0`). → tracked by #2940. ([alert #301](https://github.com/apify/apify-docs/security/dependabot/301), [#300](https://github.com/apify/apify-docs/security/dependabot/300)) - `colord` 2.9.3 → 2.9.4 — in-range per `postcss-colormin@6.1.0`'s own `^2.9.3`; `2.9.4` has been published and mature for months, yet `pnpm update colord -r` (including with a cleared metadata cache) won't move it — same resolver-bug class as `joi` above; re-verify next run. ([alert #279](https://github.com/apify/apify-docs/security/dependabot/279)) - `@faker-js/faker` 5.5.3 → 10.5.0 (HIGH) — needs a new override across a 5-major gap: pinned exactly (`5.5.3`) by `postman-collection@5.3.1` (its latest version), which hasn't picked up the rewritten faker API. ([alert #275](https://github.com/apify/apify-docs/security/dependabot/275)) - `immutable` 5.1.5 → 5.1.8 (×2 alerts) — in-range per `sass@1.107.1`'s own `^5.1.5`; `5.1.8`/`5.1.9` have been mature for months, but pnpm refuses to resolve past the locked version even with an explicit single-package target and a clean metadata cache — same resolver-bug class as `joi`/`colord` above; re-verify next run. ([alert #272](https://github.com/apify/apify-docs/security/dependabot/272), [#271](https://github.com/apify/apify-docs/security/dependabot/271)) 🤖 Generated with [Claude Code](https://claude.com/claude-code) Co-authored-by: apify-deps[bot] <4649591+apify-deps[bot]@users.noreply.github.com>
renovate
Bot
force-pushed
the
renovate/markdownlint-cli-0.x
branch
from
November 6, 2026 06:33
0588900 to
e43e03a
Compare
B4nan
approved these changes
Nov 6, 2026
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
This PR contains the following updates:
^0.49.1→^0.50.0Release Notes
igorshubovych/markdownlint-cli (markdownlint-cli)
v0.50.0Compare Source
markdownlintdependency to0.42.0MD011/MD018/MD020/MD043/MD051/MD055/MD060DependabotConfiguration
📅 Schedule: (UTC)
🚦 Automerge: Disabled by config. Please merge this manually once you are satisfied.
♻ Rebasing: Whenever PR becomes conflicted, or you tick the rebase/retry checkbox.
🔕 Ignore: Close this PR and you won't be reminded about this update again.
This PR was generated by Mend Renovate. View the repository job log.